[PRD] Rechtspraak.nl > CCBR outage

Incident Report for iLoan

Resolved

[PRD] Rechtspraak.nl > CCBR has been recovered
Posted Mar 16, 2025 - 19:23 CET

Investigating

[PRD] Rechtspraak.nl > CCBR is experiencing an outage.

Our apologies for any inconvenience this may cause.
We will notify you once the incident is resolved.
Posted Mar 16, 2025 - 18:51 CET
This incident affected: Credit services (Guardianship services).