[PRD] Logilink outage
Incident Report for iLoan
Resolved
This incident has been resolved.
Posted Jul 22, 2024 - 13:40 CEST
Investigating
[PRD] Logilink is experiencing an outage. Reported explanation: 'Provider returned SSL policy errors'

Our apologies for any inconvenience this may cause.
We will notify you once the incident is resolved.
Posted Jul 22, 2024 - 02:19 CEST
This incident affected: Credit services (Credit registration services).